xml地图|网站地图|网站标签 [设为首页] [加入收藏]
Linux忘记root密码怎么办,Legacy引导模式
分类:操作系统

基于Red Hat Enterprise Linux 7.5

启动php 提示"libc.so.6: version `GLIBC_2.14' not found",原因可能是glibc版本太低,php使用了较高的glibc版本引起的

前言

由于虚拟机运行在本人的老机器上实在是比较卡,又还不想换机器,再加上linux的向(ai)往(zhe)之(teng)情,所以决定装个ubuntu(16.04LTS)双系统,并计划将ubuntu变为以后的主要使用系统。由于本人机器相对有年头了,使用的是Legacy引导模式。(本文记于2018年6月)欢迎访问博主个人主页


1,首先查看系统glibc的版本

一、准备工作

 

$ strings /lib64/libc.so.6 |grep GLIBC_   GLIBC_2.2.5  
GLIBC_2.2.6  
GLIBC_2.3  
GLIBC_2.3.2  
GLIBC_2.3.3  
GLIBC_2.3.4  
GLIBC_2.4  
GLIBC_2.5  
GLIBC_2.6  
GLIBC_2.7  
GLIBC_2.8  
GLIBC_2.9  
GLIBC_2.10  
GLIBC_2.11  
GLIBC_2.12  
GLIBC_PRIVATE 

1.1制作U盘启动盘

图片 1

$ rpm -qa |grep glibc  
glibc-static-2.12-1.80.el6_3.6.x86_64  
glibc-headers-2.12-1.80.el6_3.6.x86_64  
glibc-common-2.12-1.80.el6_3.6.x86_64  
glibc-devel-2.12-1.80.el6_3.6.x86_64  
glibc-static-2.12-1.80.el6_3.6.i686  
glibc-devel-2.12-1.80.el6_3.6.i686  
glibc-2.12-1.80.el6_3.6.i686  
glibc-2.12-1.80.el6_3.6.x86_64 

1.1.1下载系统镜像文件

在官网下载ubuntu iso镜像文件,这里我选择的版本是16.04LTS

在启动引导主页上按e进入内核编辑

2,可以看到最高的版本是会2.12,所以考虑编译解决这个问题,下载所需要升级的版本

1.1.2制作系统U盘

下载软件软碟通
之后在文件列表中点击打开加载我们下载好的iso镜像文件
将iso文件加载完以后我们点开启动下的写入硬盘映像
然后在弹出窗口选择我们自己的U盘(不用勾选刻录校验),写入就行了
写入完成以后,我们的安装U盘就制作好了。

 

cd  /tools

1.2硬盘分区

右键点击计算机,然后点击管理就进入了管理。然后点击存储进入磁盘管理。这时候可以看看哪个盘符剩余容量较多,便在该盘符上面右键点击压缩卷,输入压缩空间量,再点击开始压缩。推荐给Ubuntu分配60G大小。当然如果硬盘空余较多,也可以给Ubuntu分配更大的空间。
压缩完以后我们可以看到有个空余空间,这时候我们不要给它分配盘符,默认这样就行了。

图片 2

wget     (需要什么版本都可以)

二、BIOS设置

本文由澳门新葡亰手机版发布于操作系统,转载请注明出处:Linux忘记root密码怎么办,Legacy引导模式

上一篇:不同域名 下一篇:澳门新葡亰手机版Linux tar命令
猜你喜欢
热门排行
精彩图文